libgdamm compilation

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

libgdamm compilation

Pavlo Solntsev-2
Hi,

Why do we have libgda-6.0 >= 5.0.2 in configure.ac? I haven't seen the
corresponding branch in libgda. Or maybe I missed something.
The recent package is libgda-5.0 therefore it looks like a typo for me.

Thanks.



--
- Pavlo Solntsev
---------------------------------------------
Sent from Evolution on GNU/Debian <www.debian.org> id="-x-evo-
selection-start-marker">

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Murray Cumming-5
On Thu, 2017-04-27 at 07:58 -0500, Pavlo Solntsev wrote:
> Hi,
>
> Why do we have libgda-6.0 >= 5.0.2 in configure.ac? I haven't seen
> the
> corresponding branch in libgda.

libgda's git master is libgda-6.0:
https://git.gnome.org/browse/libgda/tree/libgda-6.0.pc.in

>  Or maybe I missed something. 
> The recent package is libgda-5.0 therefore it looks like a typo for
> me.

--
Murray Cumming
[hidden email]
www.murrayc.com

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Pavlo Solntsev-2
Thanks.

For me it is confused to see one version in the file name and another
inside.

On Thu, 2017-04-27 at 20:37 +0200, Murray Cumming wrote:

> On Thu, 2017-04-27 at 07:58 -0500, Pavlo Solntsev wrote:
> > Hi,
> >
> > Why do we have libgda-6.0 >= 5.0.2 in configure.ac? I haven't seen
> > the
> > corresponding branch in libgda.
>
> libgda's git master is libgda-6.0:
> https://git.gnome.org/browse/libgda/tree/libgda-6.0.pc.in
>
> >  Or maybe I missed something. 
> > The recent package is libgda-5.0 therefore it looks like a typo for
> > me.
>
>
--
- Pavlo Solntsev
---------------------------------------------
Sent from Evolution on GNU/Debian <www.debian.org> id="-x-evo-
selection-start-marker">


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Murray Cumming-5
On Thu, 2017-04-27 at 14:08 -0500, Pavlo Solntsev wrote:
> Thanks. 
>
> For me it is confused to see one version in the file name and another
> inside. 

I'm sorry. I don't understand. What change are you suggesting? Maybe a
patch would make that clearer. Thanks.


Murray Cumming
[hidden email]
www.murrayc.com

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Pavlo Solntsev-2
Murray,

It looks like I was confused by the version labeling. I was able to
compile libgda (upstream version) but without libcrypto support. I
filed a bug for that. I am trying to compile libgdamm using jhbuild but
 always receive:
configure: error: Package requirements (glibmm-2.54 >= 2.45.31 libgda-
6.0 >= 5.0.2) were not met:

No package 'glibmm-2.54' found

I just found that default branch is not master. Thus, I can't get the
recent version. I am working on this case and will let you know if I
have any problem.

Thanks.



On Thu, 2017-04-27 at 22:24 +0200, Murray Cumming wrote:

> On Thu, 2017-04-27 at 14:08 -0500, Pavlo Solntsev wrote:
> > Thanks. 
> >
> > For me it is confused to see one version in the file name and
> > another
> > inside. 
>
> I'm sorry. I don't understand. What change are you suggesting? Maybe
> a
> patch would make that clearer. Thanks.
>
>
> Murray Cumming
> [hidden email]
> www.murrayc.com
>
--
- Pavlo Solntsev
---------------------------------------------
Sent from Evolution on GNU/Debian <www.debian.org> id="-x-evo-
selection-start-marker">


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Murray Cumming-5
On Thu, 2017-04-27 at 23:53 -0500, Pavlo Solntsev wrote:

> Murray,
>
> It looks like I was confused by the version labeling. I was able to
> compile libgda (upstream version) but without libcrypto support. I
> filed a bug for that. I am trying to compile libgdamm using jhbuild
> but
>  always receive:
> configure: error: Package requirements (glibmm-2.54 >= 2.45.31
> libgda-
> 6.0 >= 5.0.2) were not met:
>
> No package 'glibmm-2.54' found
>
> I just found that default branch is not master.

I don't know what default would mean here. The git master branch of
libgdamm (the libgdamm-6.0 API) builds with the master branch of libgda
(the libgda-6.0 API) and the master branch of glibmm (the glibmm-2.54
API).

At least, it's meant to.

Maybe you are sometimes talking about distro package versions (Debian,
Ubuntu, Fedora?) and sometimes about building from git.

--
Murray Cumming
[hidden email]
www.murrayc.com

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: libgdamm compilation

Pavlo Solntsev-2
I finally compiled libgdamm - master branch. Uh. All branches glib,
glibmm, libgda, and libgdamm are master's. libgda didn't go without --
disable-crypto. I compiled against libssl-dev-1.1.0e-1  , whichis default in debian testing.

Sorry, Murray, for taking your time. Your comments and suggestions were
very useful.

Best,
 

On Fri, 2017-04-28 at 08:26 +0200, Murray Cumming wrote:

> On Thu, 2017-04-27 at 23:53 -0500, Pavlo Solntsev wrote:
> > Murray,
> >
> > It looks like I was confused by the version labeling. I was able to
> > compile libgda (upstream version) but without libcrypto support. I
> > filed a bug for that. I am trying to compile libgdamm using jhbuild
> > but
> >  always receive:
> > configure: error: Package requirements (glibmm-2.54 >= 2.45.31
> > libgda-
> > 6.0 >= 5.0.2) were not met:
> >
> > No package 'glibmm-2.54' found
> >
> > I just found that default branch is not master.
>
> I don't know what default would mean here. The git master branch of
> libgdamm (the libgdamm-6.0 API) builds with the master branch of
> libgda
> (the libgda-6.0 API) and the master branch of glibmm (the glibmm-2.54
> API).
>
> At least, it's meant to.
>
> Maybe you are sometimes talking about distro package versions
> (Debian,
> Ubuntu, Fedora?) and sometimes about building from git.
>
--
- Pavlo Solntsev
---------------------------------------------
Sent from Evolution on GNU/Debian <www.debian.org> id="-x-evo-
selection-start-marker">

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list