gtkmm + WIndows + Visual 2012 (or 2013)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

gtkmm + WIndows + Visual 2012 (or 2013)

Hervé Saladin

Hi everyone,

I wrote a C++ application that builds and runs well with Visual 2010 and Gtkmm 2.

Now I'm asked to make it compatible with Microsoft Kinect V2 devices.

But Kinect V2 SDK requires Visual 2012 or 2013 (https://www.microsoft.com/en-us/download/details.aspx?id=44561)

And I can't find any pre-built gtkmm binaries compatible with a Visual version newer than 2010.

I've spent the last week trying to build it from source, without any luck : I keep getting stuck in dependencies that are not satisfied or not the right versions, or failing to build for reasons I don't understand ...

And I'm having a hard time trying to find any usefull information on Google : all I get is noise, outdated tutorials, broken links, poorly documented experimental "packages" etc ...

So far, I'm not able to use AT ALL gtkmm with Visual 2012 ou 2013 !


Can somebody please point me to either :

- pre-built binaries of gtkmm that work with Visual 2012 or 2013

- or a fully documented step by step instruction to build them from source, with links to correct version of depending libs that actually work together

I'm ready to migrate my app from gtkmm 2 to gtkmm 3, if it what it takes : any solution to make it work !

Thanks, and have a nice day,


Hervé


--

Hervé Saladin
Développeur d'applications
Équipe Développement de Plateformes
Tel : 04 72 43 60 89


LIRIS - Laboratoire d'InfoRmatique en Image et Systèmes d'information
Bâtiment Jules Vernes
17 - 19 Avenue J. Capelle
69100 Villeurbanne
http://liris.cnrs.fr/

 


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list

herve_saladin.vcf (550 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: gtkmm + WIndows + Visual 2012 (or 2013)

Luca Bacci-2
if you port your application to gtkmm3.0 you can use vcpkg
vcpkg has visual studio (2015, 2017) build recipes for gtkmm3.0 (not gtkmm2.4)

Luca

2018-04-09 15:17 GMT+02:00 Hervé Saladin <[hidden email]>:

Hi everyone,

I wrote a C++ application that builds and runs well with Visual 2010 and Gtkmm 2.

Now I'm asked to make it compatible with Microsoft Kinect V2 devices.

But Kinect V2 SDK requires Visual 2012 or 2013 (https://www.microsoft.com/en-us/download/details.aspx?id=44561)

And I can't find any pre-built gtkmm binaries compatible with a Visual version newer than 2010.

I've spent the last week trying to build it from source, without any luck : I keep getting stuck in dependencies that are not satisfied or not the right versions, or failing to build for reasons I don't understand ...

And I'm having a hard time trying to find any usefull information on Google : all I get is noise, outdated tutorials, broken links, poorly documented experimental "packages" etc ...

So far, I'm not able to use AT ALL gtkmm with Visual 2012 ou 2013 !


Can somebody please point me to either :

- pre-built binaries of gtkmm that work with Visual 2012 or 2013

- or a fully documented step by step instruction to build them from source, with links to correct version of depending libs that actually work together

I'm ready to migrate my app from gtkmm 2 to gtkmm 3, if it what it takes : any solution to make it work !

Thanks, and have a nice day,


Hervé


--

Hervé Saladin
Développeur d'applications
Équipe Développement de Plateformes
Tel : 04 72 43 60 89


LIRIS - Laboratoire d'InfoRmatique en Image et Systèmes d'information
Bâtiment Jules Vernes
17 - 19 Avenue J. Capelle
69100 Villeurbanne
http://liris.cnrs.fr/

 


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list



_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list