glibmm versions

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

glibmm versions

Gtkmm mailing list
Hi,
Could you please clarify the following. I am trying to compile
libgdamm. It requires glibmm-2.56 >= 2.45.31. What does it mean? There
is a branch 2.56 which corresponds to glibmm-2.4. How to get glibmm-
2.56? master corresponds to glibmm-2.58. I already filed bug against
jhbuild but I am ready to compile glibmm manually.

Thanks.



configure: error: Package requirements (glibmm-2.56 >= 2.45.31 libgda-
6.0 >= 5.0.2) were not met:

No package 'glibmm-2.56' found
_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: glibmm versions

Gtkmm mailing list

glibmm-2.56 was once the tentative ABI-name of a series of new ABI-breaking releases of glibmm. Now the still tentative ABI-name is glibmm-2.58. It's very confusing. I've tried to explain in a jhbuild bug.
https://bugzilla.gnome.org/show_bug.cgi?id=792047#c6
https://bugzilla.gnome.org/show_bug.cgi?id=792047#c11

You shall probably change the requirement in libgdamm to glibmm-2.58 >= 2.57.1

Kjell

On 2018-07-26 07:21, Pavlo Solntsev via gtkmm-list wrote:
Hi,
Could you please clarify the following. I am trying to compile
libgdamm. It requires glibmm-2.56 >= 2.45.31. What does it mean? There
is a branch 2.56 which corresponds to glibmm-2.4. How to get glibmm-
2.56? master corresponds to glibmm-2.58. I already filed bug against
jhbuild but I am ready to compile glibmm manually. 

Thanks.



configure: error: Package requirements (glibmm-2.56 >= 2.45.31 libgda-
6.0 >= 5.0.2) were not met:

No package 'glibmm-2.56' found



_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: glibmm versions

Gtkmm mailing list
Thank you, Kjell.

Situation with API/ABI version is really confusing. Is there any rule
you follow when you make a release? Say, new version of glibmm is
issued after new version of glib.

From jhbuild moduleset only libgdamm needs glibmm-2.58 (a la master).
Downgrade doesn't work since API for glibmm was changed between 2.4 and
2.56. It looks like only one solution here is to create a local module
set file and build all dependencies around master.

Thanks.


On Thu, 2018-07-26 at 10:40 +0200, Kjell Ahlstedt wrote:

> glibmm-2.56 was once the tentative ABI-name of a series of new ABI-
> breaking releases of glibmm. Now the still tentative ABI-name is
> glibmm-2.58. It's very confusing. I've tried to explain in a jhbuild
> bug.
> https://bugzilla.gnome.org/show_bug.cgi?id=792047#c6
> https://bugzilla.gnome.org/show_bug.cgi?id=792047#c11
> You shall probably change the requirement in libgdamm to glibmm-2.58
> >= 2.57.1
> Kjell
> On 2018-07-26 07:21, Pavlo Solntsev via gtkmm-list wrote:
> > Hi,
> > Could you please clarify the following. I am trying to compile
> > libgdamm. It requires glibmm-2.56 >= 2.45.31. What does it mean?
> > There
> > is a branch 2.56 which corresponds to glibmm-2.4. How to get
> > glibmm-
> > 2.56? master corresponds to glibmm-2.58. I already filed bug
> > against
> > jhbuild but I am ready to compile glibmm manually.
> >
> > Thanks.
> >
> >
> >
> > configure: error: Package requirements (glibmm-2.56 >= 2.45.31
> > libgda-
> > 6.0 >= 5.0.2) were not met:
> >
> > No package 'glibmm-2.56' found
> >
>  
_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: glibmm versions

Gtkmm mailing list

The gtk+ team are working on a new gtk+-4.0 ABI, parallel-installable with gtk+-3.0. The corresponding gtkmm ABI is gtkmm-4.0.
The glib team don't plan for a new glib ABI. It will still be glib-2.0. But there will be a new glibmm ABI,
parallel-installable with glibmm-2.4. Unfortunately the name of this new glibmm ABI has not yet settled. It will depend on which glib-2.0 release it will be based on, and that depends on when the gtk+-4.0 and gtkmm-4.0 ABI will become stable. That has caused the confusion with different preliminary names of the new glibmm ABI. It would perhaps have been better to use an obviously preliminary name, like for example glibmm-2X, until both the ABI and its name become stable. Then the ABI name would change just once.

It looks to me as if he jhbuild moduleset for libgdamm ought to be updated. Probably you need a libgdamm entry, downloading the master branch, and depending on gtkmm (i.e. the new gtkmm-4.0), then a libgdamm-5 entry, downloading another branch (libgdamm-5-0?), and depending on gtkmm-3.

How come libgdamm depend on gtkmm according to the jhbuild moduleset, but gtkmm is now mentioned in configure.ac?

On 2018-07-26 20:43, [hidden email] wrote:
Thank you, Kjell.

Situation with API/ABI version is really confusing. Is there any rule
you follow when you make a release? Say, new version of glibmm is
issued after new version of glib. 

From jhbuild moduleset only libgdamm needs glibmm-2.58 (a la master).
Downgrade doesn't work since API for glibmm was changed between 2.4 and
2.56. It looks like only one solution here is to create a local module
set file and build all dependencies around master. 

Thanks.


On Thu, 2018-07-26 at 10:40 +0200, Kjell Ahlstedt wrote:
glibmm-2.56 was once the tentative ABI-name of a series of new ABI-
breaking releases of glibmm. Now the still tentative ABI-name is
glibmm-2.58. It's very confusing. I've tried to explain in a jhbuild
bug.
https://bugzilla.gnome.org/show_bug.cgi?id=792047#c6
https://bugzilla.gnome.org/show_bug.cgi?id=792047#c11
You shall probably change the requirement in libgdamm to glibmm-2.58
= 2.57.1
Kjell
On 2018-07-26 07:21, Pavlo Solntsev via gtkmm-list wrote:
Hi,
Could you please clarify the following. I am trying to compile
libgdamm. It requires glibmm-2.56 >= 2.45.31. What does it mean?
There
is a branch 2.56 which corresponds to glibmm-2.4. How to get
glibmm-
2.56? master corresponds to glibmm-2.58. I already filed bug
against
jhbuild but I am ready to compile glibmm manually. 

Thanks.



configure: error: Package requirements (glibmm-2.56 >= 2.45.31
libgda-
6.0 >= 5.0.2) were not met:

No package 'glibmm-2.56' found

 


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: glibmm versions

Gtkmm mailing list
Thank you for clarification.

gtkmm for libgdamm is optional, to compile libgda-ui module and other
useful tools. There is a separate package libgda-uimm which contains
some GUI widgets for libgda. Actually, very useful widgets. But libgda-
uimm is very old and should be updated. I am contributing to the libgda
and usually build all available modules from the source libgda.
Therefore, I need dev files not just from gtk but also from gladeui.
Some code was modified to use the recent API from libgdamm and thus the
current libgdamm depends on recent API version. For now, I use C code
directly from c++ app. Will play on side with jhbuild moduleset files.

Thanks,


On Sun, 2018-07-29 at 13:04 +0200, Kjell Ahlstedt wrote:

> The gtk+ team are working on a new gtk+-4.0 ABI, parallel-installable
> with gtk+-3.0. The corresponding gtkmm ABI is gtkmm-4.0.
> The glib team don't plan for a new glib ABI. It will still be glib-
> 2.0. But there will be a new glibmm ABI, parallel-installable with
> glibmm-2.4. Unfortunately the name of this new glibmm ABI has not yet
> settled. It will depend on which glib-2.0 release it will be based
> on, and that depends on when the gtk+-4.0 and gtkmm-4.0 ABI will
> become stable. That has caused the confusion with different
> preliminary names of the new glibmm ABI. It would perhaps have been
> better to use an obviously preliminary name, like for example glibmm-
> 2X, until both the ABI and its name become stable. Then the ABI name
> would change just once.
> It looks to me as if he jhbuild moduleset for libgdamm ought to be
> updated. Probably you need a libgdamm entry, downloading the master
> branch, and depending on gtkmm (i.e. the new gtkmm-4.0), then a
> libgdamm-5 entry, downloading another branch (libgdamm-5-0?), and
> depending on gtkmm-3.
> How come libgdamm depend on gtkmm according to the jhbuild moduleset,
> but gtkmm is now mentioned in configure.ac?
> On 2018-07-26 20:43, [hidden email] wrote:
> > Thank you, Kjell.
> >
> > Situation with API/ABI version is really confusing. Is there any
> > rule
> > you follow when you make a release? Say, new version of glibmm is
> > issued after new version of glib.
> >
> > From jhbuild moduleset only libgdamm needs glibmm-2.58 (a la
> > master).
> > Downgrade doesn't work since API for glibmm was changed between 2.4
> > and
> > 2.56. It looks like only one solution here is to create a local
> > module
> > set file and build all dependencies around master.
> >
> > Thanks.
> >
> >
> > On Thu, 2018-07-26 at 10:40 +0200, Kjell Ahlstedt wrote:
> > > glibmm-2.56 was once the tentative ABI-name of a series of new
> > > ABI-
> > > breaking releases of glibmm. Now the still tentative ABI-name is
> > > glibmm-2.58. It's very confusing. I've tried to explain in a
> > > jhbuild
> > > bug.
> > > https://bugzilla.gnome.org/show_bug.cgi?id=792047#c6
> > > https://bugzilla.gnome.org/show_bug.cgi?id=792047#c11
> > > You shall probably change the requirement in libgdamm to glibmm-
> > > 2.58
> > > > = 2.57.1
> > >
> > > Kjell
> > > On 2018-07-26 07:21, Pavlo Solntsev via gtkmm-list wrote:
> > > > Hi,
> > > > Could you please clarify the following. I am trying to compile
> > > > libgdamm. It requires glibmm-2.56 >= 2.45.31. What does it
> > > > mean?
> > > > There
> > > > is a branch 2.56 which corresponds to glibmm-2.4. How to get
> > > > glibmm-
> > > > 2.56? master corresponds to glibmm-2.58. I already filed bug
> > > > against
> > > > jhbuild but I am ready to compile glibmm manually.
> > > >
> > > > Thanks.
> > > >
> > > >
> > > >
> > > > configure: error: Package requirements (glibmm-2.56 >= 2.45.31
> > > > libgda-
> > > > 6.0 >= 5.0.2) were not met:
> > > >
> > > > No package 'glibmm-2.56' found
> > > >
> > >
> > >  
>  
_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list