glibmm-2.56 or glibmm-2.58 ABI?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

glibmm-2.56 or glibmm-2.58 ABI?

Kjell Ahlstedt-2

Now glib 2.56.0 has been released.

Will glibmm 2.56.0 be released with glibmm-2.4 ABI, and will the next parallel-installable ABI be glibmm-2.58?
If so, we should take the chance to add some new API before glibmm 2.56.0 is released. E.g. as suggested in
https://bugzilla.gnome.org/show_bug.cgi?id=787496
https://bugzilla.gnome.org/show_bug.cgi?id=495762#24

Kjell


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list
Reply | Threaded
Open this post in threaded view
|

Re: glibmm-2.56 or glibmm-2.58 ABI?

Murray Cumming-5
On Wed, 2018-03-14 at 13:46 +0100, Kjell Ahlstedt wrote:
> Now glib 2.56.0 has been released.
> Will glibmm 2.56.0 be released with glibmm-2.4 ABI,

We could do that, sure, maybe by branching from the glibmm-2.54 branch.
Please feel very free to take care of that. Thanks.

>  and will the next parallel-installable ABI be glibmm-2.58?

Yes, we should change the ABI name again.

> If so, we should take the chance to add some new API before glibmm
> 2.56.0 is released. E.g. as suggested in
> https://bugzilla.gnome.org/show_bug.cgi?id=787496
> https://bugzilla.gnome.org/show_bug.cgi?id=495762#24

Sure. That should be fine.

--
Murray Cumming
[hidden email]
www.murrayc.com

_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list