compilation error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

compilation error

danny van elsen
hello,

when trying to compile  "beast-0.6.6.tar.gz"

I run into the following error:

bsesong.c: In function 'bse_type_builtin_register_BseSong':
bsesong.c:63: error: invalid storage class for function
'bse_song_class_init'
bsesong.c:64: error: invalid storage class for function 'bse_song_init'
bsesong.c:70: error: 'bse_song_class_init' undeclared (first use in this
function)
bsesong.c:70: error: (Each undeclared identifier is reported only once
bsesong.c:70: error: for each function it appears in.)
bsesong.c:76: error: 'bse_song_init' undeclared (first use in this function)
make[3]: *** [bsesong.lo] Error 1

does anyone know how to fix this?

greetings, Danny.

(
I am using gcc:
gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)
)
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast
Reply | Threaded
Open this post in threaded view
|

Re: compilation error

Tim Janik-2
On Sun, 18 Dec 2005, danny van elsen wrote:

> hello,
>
> when trying to compile  "beast-0.6.6.tar.gz"
>
> I run into the following error:
>
> bsesong.c: In function 'bse_type_builtin_register_BseSong':
> bsesong.c:63: error: invalid storage class for function 'bse_song_class_init'
> bsesong.c:64: error: invalid storage class for function 'bse_song_init'
> bsesong.c:70: error: 'bse_song_class_init' undeclared (first use in this
> function)
> bsesong.c:70: error: (Each undeclared identifier is reported only once
> bsesong.c:70: error: for each function it appears in.)
> bsesong.c:76: error: 'bse_song_init' undeclared (first use in this function)
> make[3]: *** [bsesong.lo] Error 1
>
> does anyone know how to fix this?
>
> greetings, Danny.

these are problems only gcc-4.0 runs into. for beast-0.6.6, the
solution is to actually compile beast with gcc-3.3 or gcc-3.4.
we're working on making the next release compile with gcc-4.0.

>
> (
> I am using gcc:
> gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)
> )

---
ciaoTJ
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast