audigy LS

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

audigy LS

danny van elsen
hello all,

I have a AUDIGY LS sound card, operating with the oss driver from
http://www.opensound.com/

The box says that it is 'MIDI' compatible. Unfortunately, beast doesn't
seem to generate sound on this card; it opens alle example files fine,
but there is never any output... could anyone point to the most probable
source of error?

greetings, D.
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast
Reply | Threaded
Open this post in threaded view
|

Re: audigy LS

Tim Janik
On Mon, 23 Jan 2006, danny van elsen wrote:

> hello all,
>
> I have a AUDIGY LS sound card, operating with the oss driver from
> http://www.opensound.com/
>
> The box says that it is 'MIDI' compatible. Unfortunately, beast doesn't seem
> to generate sound on this card; it opens alle example files fine, but there
> is never any output... could anyone point to the most probable source of
> error?

do other sound applications work? beast isn't special in what it does
with /dev/dsp and /dev/midi.


>
> greetings, D.
> _______________________________________________
> beast mailing list
> [hidden email]
> http://mail.gnome.org/mailman/listinfo/beast
>

---
ciaoTJ
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast
Reply | Threaded
Open this post in threaded view
|

Re: audigy LS

danny van elsen
hi Tim,

yes , other applications do work: xine, mplayer, rhtythmbox, ...

(only the flashplayer plugin for mozilla doesn't produce sound, but that
seems to be a known limitation ...)

greetings, D.

Tim Janik wrote:

> On Mon, 23 Jan 2006, danny van elsen wrote:
>
>> hello all,
>>
>> I have a AUDIGY LS sound card, operating with the oss driver from
>> http://www.opensound.com/
>>
>> The box says that it is 'MIDI' compatible. Unfortunately, beast
>> doesn't seem to generate sound on this card; it opens alle example
>> files fine, but there is never any output... could anyone point to
>> the most probable source of error?
>
>
> do other sound applications work? beast isn't special in what it does
> with /dev/dsp and /dev/midi.

_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast
Reply | Threaded
Open this post in threaded view
|

Re: audigy LS

Tim Janik
On Sun, 29 Jan 2006, danny van elsen wrote:

> hi Tim,
>
> yes , other applications do work: xine, mplayer, rhtythmbox, ...
>
> (only the flashplayer plugin for mozilla doesn't produce sound, but that
> seems to be a known limitation ...)
>
> greetings, D.

ok, we can try debugging the exact setup steps required on your machine if
you want. for that, take dsptest1.c, compile it:
$ gcc -Wall -O2 -g `pkg-config --cflags --libs glib-2.0` dsptest1.c -o dsptest1
and run it on your machine, giving it your sound device:
$ ./dsptest1 /dev/dsp
OSS: setup: w=1 r=1 n_channels=2 mix_freq=44100 queue=2205 nfrags=117 fsize=128 bufsz=14976
open(/dev/dsp) result: Everything went well

that way we can figure:
a) if it fails for you
b) the next thing will be to figure *where* it fails for you
c) what to do to fix sound driver initialization for you


---
ciaoTJ
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast

dsptest1.c (21K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: audigy LS

danny van elsen
hello Tim,

I get the following:

./dsptest1 /dev/dsp
OSS: buffer size (60241) differs from fragment space (60416)
OSS: setup: w=1 r=1 n_channels=2 mix_freq=44100 queue=2205 nfrags=128
fsize=118 bufsz=15060
open(/dev/dsp) result: Everything went well

however, since I do get an error
'Warning: Some of the devices failed to initialize'
I am also including the startup log for the OSS driver, but this is
perhaps more something for audigy, not for 'beast'?
(although it still doesn't explain why all other applications work...)

many greetings!
Danny.

*********************************************************
Tim Janik wrote:

> On Sun, 29 Jan 2006, danny van elsen wrote:
>
>> hi Tim,
>>
>> yes , other applications do work: xine, mplayer, rhtythmbox, ...
>>
>> (only the flashplayer plugin for mozilla doesn't produce sound, but
>> that seems to be a known limitation ...)
>>
>> greetings, D.
>
>
> ok, we can try debugging the exact setup steps required on your
> machine if
> you want. for that, take dsptest1.c, compile it:
> $ gcc -Wall -O2 -g `pkg-config --cflags --libs glib-2.0` dsptest1.c -o
> dsptest1
> and run it on your machine, giving it your sound device:
> $ ./dsptest1 /dev/dsp OSS: setup: w=1 r=1 n_channels=2 mix_freq=44100
> queue=2205 nfrags=117 fsize=128 bufsz=14976
> open(/dev/dsp) result: Everything went well
>
> that way we can figure:
> a) if it fails for you
> b) the next thing will be to figure *where* it fails for you
> c) what to do to fix sound driver initialization for you
>
>

OSS version: 3.99.3d
OSS build: 200512232307
Kernel version: Linux stille-pc 2.6.13-15-smp #4 SMP Sun Jan 8 20:44:23 CET 2006 i686 i686 i386 GNU/Linux
Kernel vermagic: 2.6.13-15-smp SMP 586 REGPARM gcc-4.0
Modutils version: 3.2-pre8
 10:21am  up   0:00,  0 users,  load average: 2.54, 0.53, 0.17
=== Running /usr/lib/oss/bin/soundon ===
Install directory: /usr/lib/oss
Loading OSS/Linux module
==== About to start the driver using the following config ===
# Use soundconf to edit this file.
/SECUREAUDIO OFF
/IRQEXCLUDE 3 4
/DMAEXCLUDE 2
-PCI00071102 #Sound Blaster Audigy LS
AUDIGYLS ON
-PCI70121039 #SiS 7012
UART401 ON P330 I5
INTELPCI ON
++ pnpres.dat ++
++++
Config option 'softoss_disable=0' defined
Warning: Some of the devices failed to initialize
OSS/Linux 3.99.3d (C) 4Front Technologies 1996-2004

License serial number: E00000008
**** UNREGISTERED VERSION ****

Drivers: ALL
License will expire after: 06/2006


*** Unregistered version ***

Build: 200512232307

Card config:
Audigy-LS at 0xd800 irq 209
(MPU-401 (UART) at 0x330 irq 5)
Intel ICH AC97 audio controller at 0xd400 irq 209

Audio devices:
0: AudigyLS front (GRC3)
1: AudigyLS center/lfe (GRC3)
2: AudigyLS record (GRC3)
3: AudigyLS surround (GRC3)
4: AudigyLS 4.0 output (GRC3)
5: SiS 7012 (DUPLEX,GRC3)
6: SiS 7012 (shadow) (DUPLEX,GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
10: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
11: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
12: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
13: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
14: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:
0: AudigyLS UART

Mixers:
0: AudigyLS (STAC9721)
1: AC97 Mixer (ALC655)
2: Virtual Mixer


++++
crw-rw-rw-  1 root root 14,  14 Feb 10 10:21 /dev/dsp
crw-rw-rw-  1 root root 14,   3 Feb 10 10:21 /dev/dsp0
crw-rw-rw-  1 root root 14,  19 Feb 10 10:21 /dev/dsp1
crw-rw-rw-  1 root root 14, 163 Feb 10 10:21 /dev/dsp10
crw-rw-rw-  1 root root 14, 179 Feb 10 10:21 /dev/dsp11
crw-rw-rw-  1 root root 14, 195 Feb 10 10:21 /dev/dsp12
crw-rw-rw-  1 root root 14, 211 Feb 10 10:21 /dev/dsp13
crw-rw-rw-  1 root root 14, 227 Feb 10 10:21 /dev/dsp14
crw-rw-rw-  1 root root 14, 243 Feb 10 10:21 /dev/dsp15
crw-rw-rw-  1 root root 14,  35 Feb 10 10:21 /dev/dsp2
crw-rw-rw-  1 root root 14,  51 Feb 10 10:21 /dev/dsp3
crw-rw-rw-  1 root root 14,  67 Feb 10 10:21 /dev/dsp4
crw-rw-rw-  1 root root 14,  83 Feb 10 10:21 /dev/dsp5
crw-rw-rw-  1 root root 14,  99 Feb 10 10:21 /dev/dsp6
crw-rw-rw-  1 root root 14, 115 Feb 10 10:21 /dev/dsp7
crw-rw-rw-  1 root root 14, 131 Feb 10 10:21 /dev/dsp8
crw-rw-rw-  1 root root 14, 147 Feb 10 10:21 /dev/dsp9
lrwxrwxrwx  1 root root      10 Feb 10 10:21 /dev/dspW -> /dev/dspW0
crw-rw-rw-  1 root root 14,   5 Feb 10 10:21 /dev/dspW0
crw-rw-rw-  1 root root 14,  21 Feb 10 10:21 /dev/dspW1
crw-rw-rw-  1 root root 14, 165 Feb 10 10:21 /dev/dspW10
crw-rw-rw-  1 root root 14, 181 Feb 10 10:21 /dev/dspW11
crw-rw-rw-  1 root root 14, 197 Feb 10 10:21 /dev/dspW12
crw-rw-rw-  1 root root 14, 213 Feb 10 10:21 /dev/dspW13
crw-rw-rw-  1 root root 14, 229 Feb 10 10:21 /dev/dspW14
crw-rw-rw-  1 root root 14, 245 Feb 10 10:21 /dev/dspW15
crw-rw-rw-  1 root root 14,  37 Feb 10 10:21 /dev/dspW2
crw-rw-rw-  1 root root 14,  53 Feb 10 10:21 /dev/dspW3
crw-rw-rw-  1 root root 14,  69 Feb 10 10:21 /dev/dspW4
crw-rw-rw-  1 root root 14,  85 Feb 10 10:21 /dev/dspW5
crw-rw-rw-  1 root root 14, 101 Feb 10 10:21 /dev/dspW6
crw-rw-rw-  1 root root 14, 117 Feb 10 10:21 /dev/dspW7
crw-rw-rw-  1 root root 14, 133 Feb 10 10:21 /dev/dspW8
crw-rw-rw-  1 root root 14, 149 Feb 10 10:21 /dev/dspW9
lrwxrwxrwx  1 root root       9 Feb 10 10:21 /dev/dsp_ac3 -> /dev/dsp0
lrwxrwxrwx  1 root root       8 Feb 10 10:21 /dev/dsp_mmap -> /dev/dsp
lrwxrwxrwx  1 root root       9 Feb 10 10:21 /dev/dsp_multich -> /dev/dsp4
++++ dmesg printout follows ++++
Linux version 2.6.13-15-smp (geeko@buildhost) (gcc version 4.0.2 20050901 (prerelease) (SUSE Linux)) #4 SMP Sun Jan 8 20:44:23 CET 2006
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
 BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003fff0000 (usable)
 BIOS-e820: 000000003fff0000 - 000000003fff3000 (ACPI NVS)
 BIOS-e820: 000000003fff3000 - 0000000040000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
127MB HIGHMEM available.
896MB LOWMEM available.
found SMP MP-table at 000f5910
On node 0 totalpages: 262128
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 225280 pages, LIFO batch:31
  HighMem zone: 32752 pages, LIFO batch:15
DMI 2.2 present.
Using APIC driver default
ACPI: RSDP (v000 AWARD                                 ) @ 0x000f7270
ACPI: RSDT (v001 AWARD  AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3000
ACPI: FADT (v001 AWARD  AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3040
ACPI: MADT (v001 AWARD  AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff6a00
ACPI: DSDT (v001 AWARD  AWRDACPI 0x00001000 MSFT 0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 15:2 APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
Processor #1 15:2 APIC version 20
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 2, version 20, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 dfl dfl)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 40000000 (gap: 40000000:bec00000)
Built 1 zonelists
Kernel command line: BOOT_IMAGE=Linux ro root=302 selinux=0 resume=/dev/hda1 splash=silent showopts
bootsplash: silent mode.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 65536 bytes)
Detected 2806.748 MHz processor.
Using pmtmr for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 1032384k/1048512k available (2389k kernel code, 15352k reserved, 767k data, 256k init, 131008k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 5617.53 BogoMIPS (lpj=11235068)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Mount-cache hash table entries: 512
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 00004400 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 00004400 00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 00004400 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU0: Thermal monitoring enabled
mtrr: v2.0 (20020519)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
checking if image is initramfs... it is
Freeing initrd memory: 1396k freed
ACPI: Looking for DSDT in initrd... not found!
 not found!
CPU0: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 09
Booting processor 1/1 eip 3000
Initializing CPU#1
Calibrating delay using timer specific routine.. 5613.18 BogoMIPS (lpj=11226372)
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 00004400 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 00004400 00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebfbff 00000000 00000000 00000080 00004400 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: Intel P4/Xeon Extended MCE MSRs (12) available
CPU1: Thermal monitoring enabled
CPU1: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 09
Total of 2 processors activated (11230.72 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking TSC synchronization across 2 CPUs: passed.
Brought up 2 CPUs
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfb510, last bus=1
PCI: Using configuration type 1
ACPI: Subsystem revision 20050408
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
ACPI: Assume root bridge [\_SB_.PCI0] segment is 0
ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
PCI: Ignoring BAR0-3 of IDE controller 0000:00:02.5
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 *10 11 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 *11 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 *10 11 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 *11 14 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 *9 10 11 14 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 9 10 11 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 11 devices
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
TC classifier action (bugs to [hidden email] cc [hidden email])
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: e0000000-e1ffffff
  PREFETCH window: d8000000-dfffffff
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
apm: disabled - APM is not SMP safe.
audit: initializing netlink socket (disabled)
audit(1139566868.040:1): initialized
highmem bounce pool size: 64 pages
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
vesafb: framebuffer at 0xd8000000, mapped to 0xf8880000, using 10240k, total 131072k
vesafb: mode is 1280x1024x16, linelength=2560, pages=1
vesafb: protected mode interface info at c000:f090
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 160x64
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
PNP: PS/2 controller doesn't have AUX irq; using default 0xc
PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 112
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 64000K size 1024 blocksize
loop: loaded (max 8 devices)
mice: PS/2 mouse device common for all mice
input: PC Speaker
md: md driver 0.90.2 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 3.38
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 6, 262144 bytes)
TCP established hash table entries: 262144 (order: 9, 2097152 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP reno registered
ip_conntrack version 2.1 (8191 buckets, 65528 max) - 248 bytes per conntrack
input: AT Translated Set 2 keyboard on isa0060/serio0
ip_tables: (C) 2000-2002 Netfilter core team
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Starting balanced_irq
Using IPI No-Shortcut mode
ACPI wakeup devices:
FUTS PCI0 USB0 USB1 USB2 USB3 AMR0 UAR1 UAR2 PS2K
ACPI: (supports S0 S3 S4 S5)
Freeing unused kernel memory: 256k freed
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 0000:00:02.5
    ACPI-0212: *** Warning: Device is not power manageable
ACPI: PCI Interrupt 0000:00:02.5[A] -> GSI 16 (level, low) -> IRQ 169
SIS5513: chipset revision 1
SIS5513: not 100% native mode: will probe irqs later
SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller
    ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
hda: WDC WD1600JB-00FUA0, ATA DISK drive
hdb: Maxtor 6L200P0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 1024KiB
hda: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 >
hdb: max request size: 1024KiB
hdb: 398297088 sectors (203928 MB) w/8192KiB Cache, CHS=24792/255/63, UDMA(133)
hdb: cache flushes supported
 hdb: hdb1 hdb2
Probing IDE interface ide1...
hdc: SONY CD-RW CRX300E, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 48X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ACPI: CPU0 (power states: C1[C1])
ACPI: CPU1 (power states: C1[C1])
ACPI: Thermal Zone [THRM] (40 C)
ACPI: Fan [FAN] (on)
Attempting manual resume
swsusp: Suspend partition has wrong signature?
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Adding 1052216k swap on /dev/hda1.  Priority:42 extents:1
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: [hidden email]
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
lp0: using parport0 (interrupt-driven).
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hdb2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
gameport: EMU10K1 is pci0000:00:0a.1/gameport0, io 0xdc00, speed 1217kHz
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt 0000:00:03.0[A] -> GSI 20 (level, low) -> IRQ 177
ohci_hcd 0000:00:03.0: OHCI Host Controller
ohci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:03.0: irq 177, io mem 0xe2000000
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected SiS 661 chipset
agpgart: AGP aperture is 128M @ 0xd0000000
8139too Fast Ethernet driver 0.9.27
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
ACPI: PCI Interrupt 0000:00:03.1[B] -> GSI 21 (level, low) -> IRQ 185
ohci_hcd 0000:00:03.1: OHCI Host Controller
ohci_hcd 0000:00:03.1: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:03.1: irq 185, io mem 0xe2001000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ACPI: PCI Interrupt 0000:00:03.2[C] -> GSI 22 (level, low) -> IRQ 193
ohci_hcd 0000:00:03.2: OHCI Host Controller
ohci_hcd 0000:00:03.2: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:03.2: irq 193, io mem 0xe2002000
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
    ACPI-0212: *** Warning: Device is not power manageable
ACPI: PCI Interrupt 0000:00:03.3[D] -> GSI 23 (level, low) -> IRQ 201
ehci_hcd 0000:00:03.3: EHCI Host Controller
ehci_hcd 0000:00:03.3: new USB bus registered, assigned bus number 4
ehci_hcd 0000:00:03.3: irq 201, io mem 0xe2003000
PCI: cache line size of 128 is not supported by device 0000:00:03.3
ehci_hcd 0000:00:03.3: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 8 ports detected
ACPI: PCI Interrupt 0000:00:0e.0[A] -> GSI 18 (level, low) -> IRQ 209
eth0: RealTek RTL8139 at 0xf882c000, 00:0d:87:a4:b0:5b, IRQ 209
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
usb 2-2: new full speed USB device using ohci_hcd and address 2
NET: Registered protocol family 8
NET: Registered protocol family 20
usb 2-2: reset full speed USB device using ohci_hcd and address 2
usbcore: registered new driver speedtch
speedtch 2-2:1.0: found stage 1 firmware speedtch-1.bin
speedtch 2-2:1.0: found stage 2 firmware speedtch-2.bin
osslinux: module license 'Open Sound System' taints kernel.
ATM dev 0: ADSL line is synchronising
ACPI: PCI Interrupt 0000:00:0a.0[A] -> GSI 18 (level, low) -> IRQ 209
oss: Probing the hardware for MPU-401 (UART) failed.
    ACPI-0212: *** Warning: Device is not power manageable
ACPI: PCI Interrupt 0000:00:02.7[C] -> GSI 18 (level, low) -> IRQ 209
++++++++
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host (rev 11)
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32
        Memory at d0000000 (32-bit, non-prefetchable) [size=128M]
        Capabilities: [c0] AGP version 3.5

00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge) (prog-if 00 [Normal decode])
        Flags: bus master, 66MHz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        Memory behind bridge: e0000000-e1ffffff
        Prefetchable memory behind bridge: d8000000-dfffffff

00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
        Flags: bus master, medium devsel, latency 0

00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01) (prog-if 80 [Master])
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 128, IRQ 169
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at 4000 [size=16]
        Capabilities: [58] Power Management version 2

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 209
        I/O ports at d000 [size=256]
        I/O ports at d400 [size=128]
        Capabilities: [48] Power Management version 2

00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 177
        Memory at e2000000 (32-bit, non-prefetchable) [size=4K]

00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 185
        Memory at e2001000 (32-bit, non-prefetchable) [size=4K]

00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 193
        Memory at e2002000 (32-bit, non-prefetchable) [size=4K]

00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller (prog-if 20 [EHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 201
        Memory at e2003000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [50] Power Management version 2

00:0a.0 Multimedia audio controller: Creative Labs SB Audigy LS
        Subsystem: Creative Labs SB0312 Audigy LS
        Flags: bus master, medium devsel, latency 32, IRQ 209
        I/O ports at d800 [size=32]
        Capabilities: [dc] Power Management version 2

00:0a.1 Input device controller: Creative Labs SB Audigy LS MIDI/Game port
        Subsystem: Creative Labs SB0312 Audigy LS MIDI/Game port
        Flags: bus master, medium devsel, latency 32
        I/O ports at dc00 [size=8]
        Capabilities: [dc] Power Management version 2

00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: ABIT Computer Corp.: Unknown device 1806
        Flags: bus master, medium devsel, latency 32, IRQ 209
        I/O ports at e000 [size=256]
        Memory at e2004000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 80df
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 10
        Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        [virtual] Expansion ROM at e1000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0

++++++++
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 06b9:4061 Alcatel Telecom SpeedTouch ISDN or ADSL Modem
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000  
++++++++
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping : 9
cpu MHz : 2806.748
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 5617.53

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping : 9
cpu MHz : 2806.748
cache size : 512 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips : 5613.18

++++
           CPU0       CPU1      
  0:       4233          0    IO-APIC-edge  timer
  1:          8          0    IO-APIC-edge  i8042
  7:          0          0    IO-APIC-edge  parport0
  8:          2          0    IO-APIC-edge  rtc
  9:          0          0   IO-APIC-level  acpi
 14:       2626          0    IO-APIC-edge  ide0
 15:         72          0    IO-APIC-edge  ide1
177:          0          0   IO-APIC-level  ohci_hcd:usb1
185:        444          0   IO-APIC-level  ohci_hcd:usb2
193:          0          0   IO-APIC-level  ohci_hcd:usb3
201:          2          0   IO-APIC-level  ehci_hcd:usb4
209:          1          0   IO-APIC-level  AudigyLS, SiS 7012
NMI:          0          0
LOC:       4135       4184
ERR:          0
MIS:          0
Redirecting /usr/lib/libasound.so.2 -> libsalsa

_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast
Reply | Threaded
Open this post in threaded view
|

Re: audigy LS

Tim Janik
On Fri, 10 Feb 2006, danny van elsen wrote:

> hello Tim,
>
> I get the following:
>
> ./dsptest1 /dev/dsp
> OSS: buffer size (60241) differs from fragment space (60416)
> OSS: setup: w=1 r=1 n_channels=2 mix_freq=44100 queue=2205 nfrags=128
> fsize=118 bufsz=15060
> open(/dev/dsp) result: Everything went well

erm, that shouldn't have happened according to your email.
the people in the thread you linked to have problems with the
device initialization which works on your machine.
so please provide an exact description of the problems you
encounter when starting beast on your machine.

> many greetings!
> Danny.
>

---
ciaoTJ
_______________________________________________
beast mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/beast