Shall libgdkmm-4.0 be merged with libgtkmm-4.0?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Shall libgdkmm-4.0 be merged with libgtkmm-4.0?

Gtkmm mailing list

This post concerns only gtkmm-4.0, wrapping the still very unstable gtk4.

Gtk4 installs only one library file and one .pc file. Bug https://bugzilla.gnome.org/show_bug.cgi?id=773100 discusses the change from three installed libraries (gdk, gsk and gtk) to one (gtk) with all code from the three directories gdk, gsk, gtk.

Should we do the same in gtkmm? Skipping (at least not installing) libgdkmm instead of adding libgskmm, when we start wrapping classes in the gtk+/gsk directory?

I think it's a good idea. See https://gitlab.gnome.org/GNOME/gtkmm/issues/48, where comments can be added.


_______________________________________________
gtkmm-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtkmm-list