[PHP-BUG] Bug #52274 [NEW]: Patch for building php-gtk with scintilla on Ubuntu

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[PHP-BUG] Bug #52274 [NEW]: Patch for building php-gtk with scintilla on Ubuntu

Guthrie at att dot net
From:            
Operating system: Ubuntu 10.04
PHP version:      5.3.2
Package:          PHP-GTK related
Bug Type:         Bug
Bug description:Patch for building php-gtk with scintilla on Ubuntu

Description:
------------
I've created a patch which makes it possible to build php-gtk with
scintilla on Ubuntu/Linux. The patch will break things on other platforms,
so someone with better knowledge of configure/make will have to figure out
a proper fix.



Description of changes:



ext/scintilla/config.m4

    Added missing source files for scintilla



ext/scintilla/libscintilla/include/Platform.h

    Set #define PLAT_GTK 1 - this is not done automatically for some
reason.



ext/scintilla/libscintilla/src/ExternalLexer.h

    Removed EXT_LEXER_DECL definition from typedefs.



ext/scintilla/sci_generator.php

    Fixed to be compatible with the new LineOutput class. Also removed
deprecated functions and warnings.



There is also some dependency problem in the makefile, so one has to
manually make gen_scintilla.c:



make ext/scintilla/gen_scintilla.c

make


--
Edit bug report at http://bugs.php.net/bug.php?id=52274&edit=1
--
Try a snapshot (PHP 5.2):            http://bugs.php.net/fix.php?id=52274&r=trysnapshot52
Try a snapshot (PHP 5.3):            http://bugs.php.net/fix.php?id=52274&r=trysnapshot53
Try a snapshot (trunk):              http://bugs.php.net/fix.php?id=52274&r=trysnapshottrunk
Fixed in SVN:                        http://bugs.php.net/fix.php?id=52274&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=52274&r=needdocs
Fixed in release:                    http://bugs.php.net/fix.php?id=52274&r=alreadyfixed
Need backtrace:                      http://bugs.php.net/fix.php?id=52274&r=needtrace
Need Reproduce Script:               http://bugs.php.net/fix.php?id=52274&r=needscript
Try newer version:                   http://bugs.php.net/fix.php?id=52274&r=oldversion
Not developer issue:                 http://bugs.php.net/fix.php?id=52274&r=support
Expected behavior:                   http://bugs.php.net/fix.php?id=52274&r=notwrong
Not enough info:                     http://bugs.php.net/fix.php?id=52274&r=notenoughinfo
Submitted twice:                     http://bugs.php.net/fix.php?id=52274&r=submittedtwice
register_globals:                    http://bugs.php.net/fix.php?id=52274&r=globals
PHP 4 support discontinued:          http://bugs.php.net/fix.php?id=52274&r=php4
Daylight Savings:                    http://bugs.php.net/fix.php?id=52274&r=dst
IIS Stability:                       http://bugs.php.net/fix.php?id=52274&r=isapi
Install GNU Sed:                     http://bugs.php.net/fix.php?id=52274&r=gnused
Floating point limitations:          http://bugs.php.net/fix.php?id=52274&r=float
No Zend Extensions:                  http://bugs.php.net/fix.php?id=52274&r=nozend
MySQL Configuration Error:           http://bugs.php.net/fix.php?id=52274&r=mysqlcfg


--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Bug #52274 [Opn->Asn]: Patch for building php-gtk with scintilla on Ubuntu

Felipe Pena-2
Edit report at http://bugs.php.net/bug.php?id=52274&edit=1

 ID:               52274
 Updated by:       [hidden email]
 Reported by:      thomas dot sahlin at invented dot se
 Summary:          Patch for building php-gtk with scintilla on Ubuntu
-Status:           Open
+Status:           Assigned
 Type:             Bug
 Package:          PHP-GTK related
 Operating System: Ubuntu 10.04
 PHP Version:      5.3.2
-Assigned To:      
+Assigned To:      auroraeosrose



Previous Comments:
------------------------------------------------------------------------
[2010-07-07 13:05:03] thomas dot sahlin at invented dot se

Description:
------------
I've created a patch which makes it possible to build php-gtk with
scintilla on Ubuntu/Linux. The patch will break things on other
platforms, so someone with better knowledge of configure/make will have
to figure out a proper fix.



Description of changes:



ext/scintilla/config.m4

    Added missing source files for scintilla



ext/scintilla/libscintilla/include/Platform.h

    Set #define PLAT_GTK 1 - this is not done automatically for some
reason.



ext/scintilla/libscintilla/src/ExternalLexer.h

    Removed EXT_LEXER_DECL definition from typedefs.



ext/scintilla/sci_generator.php

    Fixed to be compatible with the new LineOutput class. Also removed
deprecated functions and warnings.



There is also some dependency problem in the makefile, so one has to
manually make gen_scintilla.c:



make ext/scintilla/gen_scintilla.c

make



------------------------------------------------------------------------



--
Edit this bug report at http://bugs.php.net/bug.php?id=52274&edit=1

--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Bug #52274 [Asn->Ana]: Patch for building php-gtk with scintilla on Ubuntu

buhlerax
In reply to this post by Guthrie at att dot net
Edit report at https://bugs.php.net/bug.php?id=52274&edit=1

 ID:                 52274
 Updated by:         [hidden email]
 Reported by:        thomas dot sahlin at invented dot se
 Summary:            Patch for building php-gtk with scintilla on Ubuntu
-Status:             Assigned
+Status:             Analyzed
 Type:               Bug
 Package:            PHP-GTK related
 Operating System:   Ubuntu 10.04
 PHP Version:        5.3.2
 Assigned To:        buhlerax
 Block user comment: N
 Private report:     N

 New Comment:

The 2.0.1 version of php-gtk will no longer fixes.
We will work on version 3 of the php-gtk with gtk 3.


Previous Comments:
------------------------------------------------------------------------
[2010-07-07 13:05:03] thomas dot sahlin at invented dot se

Description:
------------
I've created a patch which makes it possible to build php-gtk with scintilla on Ubuntu/Linux. The patch will break things on other platforms, so someone with better knowledge of configure/make will have to figure out a proper fix.

Description of changes:

ext/scintilla/config.m4
    Added missing source files for scintilla

ext/scintilla/libscintilla/include/Platform.h
    Set #define PLAT_GTK 1 - this is not done automatically for some reason.

ext/scintilla/libscintilla/src/ExternalLexer.h
    Removed EXT_LEXER_DECL definition from typedefs.

ext/scintilla/sci_generator.php
    Fixed to be compatible with the new LineOutput class. Also removed deprecated functions and warnings.

There is also some dependency problem in the makefile, so one has to manually make gen_scintilla.c:

make ext/scintilla/gen_scintilla.c
make



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=52274&edit=1

--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Bug #52274 [Ana->Asn]: Patch for building php-gtk with scintilla on Ubuntu

Kalle Sommer Nielsen
In reply to this post by Guthrie at att dot net
Edit report at https://bugs.php.net/bug.php?id=52274&edit=1

 ID:                 52274
 Updated by:         [hidden email]
 Reported by:        thomas dot sahlin at invented dot se
 Summary:            Patch for building php-gtk with scintilla on Ubuntu
-Status:             Analyzed
+Status:             Assigned
 Type:               Bug
 Package:            PHP-GTK related
 Operating System:   Ubuntu 10.04
 PHP Version:        5.3.2
 Assigned To:        buhlerax
 Block user comment: N
 Private report:     N



Previous Comments:
------------------------------------------------------------------------
[2016-10-23 15:56:04] [hidden email]

The 2.0.1 version of php-gtk will no longer fixes.
We will work on version 3 of the php-gtk with gtk 3.

------------------------------------------------------------------------
[2010-07-07 13:05:03] thomas dot sahlin at invented dot se

Description:
------------
I've created a patch which makes it possible to build php-gtk with scintilla on Ubuntu/Linux. The patch will break things on other platforms, so someone with better knowledge of configure/make will have to figure out a proper fix.

Description of changes:

ext/scintilla/config.m4
    Added missing source files for scintilla

ext/scintilla/libscintilla/include/Platform.h
    Set #define PLAT_GTK 1 - this is not done automatically for some reason.

ext/scintilla/libscintilla/src/ExternalLexer.h
    Removed EXT_LEXER_DECL definition from typedefs.

ext/scintilla/sci_generator.php
    Fixed to be compatible with the new LineOutput class. Also removed deprecated functions and warnings.

There is also some dependency problem in the makefile, so one has to manually make gen_scintilla.c:

make ext/scintilla/gen_scintilla.c
make



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=52274&edit=1

--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Bug #52274 [Asn->Opn]: Patch for building php-gtk with scintilla on Ubuntu

Kalle Sommer Nielsen
In reply to this post by Guthrie at att dot net
Edit report at https://bugs.php.net/bug.php?id=52274&edit=1

 ID:                 52274
 Updated by:         [hidden email]
 Reported by:        thomas dot sahlin at invented dot se
 Summary:            Patch for building php-gtk with scintilla on Ubuntu
-Status:             Assigned
+Status:             Open
 Type:               Bug
 Package:            PHP-GTK related
 Operating System:   Ubuntu 10.04
 PHP Version:        5.3.2
-Assigned To:        buhlerax
+Assigned To:        
 Block user comment: N
 Private report:     N



Previous Comments:
------------------------------------------------------------------------
[2016-10-23 15:56:04] [hidden email]

The 2.0.1 version of php-gtk will no longer fixes.
We will work on version 3 of the php-gtk with gtk 3.

------------------------------------------------------------------------
[2010-07-07 13:05:03] thomas dot sahlin at invented dot se

Description:
------------
I've created a patch which makes it possible to build php-gtk with scintilla on Ubuntu/Linux. The patch will break things on other platforms, so someone with better knowledge of configure/make will have to figure out a proper fix.

Description of changes:

ext/scintilla/config.m4
    Added missing source files for scintilla

ext/scintilla/libscintilla/include/Platform.h
    Set #define PLAT_GTK 1 - this is not done automatically for some reason.

ext/scintilla/libscintilla/src/ExternalLexer.h
    Removed EXT_LEXER_DECL definition from typedefs.

ext/scintilla/sci_generator.php
    Fixed to be compatible with the new LineOutput class. Also removed deprecated functions and warnings.

There is also some dependency problem in the makefile, so one has to manually make gen_scintilla.c:

make ext/scintilla/gen_scintilla.c
make



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=52274&edit=1

--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Bug #52274 [Opn->Sus]: Patch for building php-gtk with scintilla on Ubuntu

Kalle Sommer Nielsen
In reply to this post by Guthrie at att dot net
Edit report at https://bugs.php.net/bug.php?id=52274&edit=1

 ID:                 52274
 Updated by:         [hidden email]
 Reported by:        thomas dot sahlin at invented dot se
 Summary:            Patch for building php-gtk with scintilla on Ubuntu
-Status:             Open
+Status:             Suspended
 Type:               Bug
 Package:            PHP-GTK related
 Operating System:   Ubuntu 10.04
 PHP Version:        5.3.2
 Block user comment: N
 Private report:     N

 New Comment:

I'm gonna suspend this report as the PHP GTK project activity seems halted, if the activity picks backup for the project then this report should be re-opened.


Previous Comments:
------------------------------------------------------------------------
[2016-10-23 15:56:04] [hidden email]

The 2.0.1 version of php-gtk will no longer fixes.
We will work on version 3 of the php-gtk with gtk 3.

------------------------------------------------------------------------
[2010-07-07 13:05:03] thomas dot sahlin at invented dot se

Description:
------------
I've created a patch which makes it possible to build php-gtk with scintilla on Ubuntu/Linux. The patch will break things on other platforms, so someone with better knowledge of configure/make will have to figure out a proper fix.

Description of changes:

ext/scintilla/config.m4
    Added missing source files for scintilla

ext/scintilla/libscintilla/include/Platform.h
    Set #define PLAT_GTK 1 - this is not done automatically for some reason.

ext/scintilla/libscintilla/src/ExternalLexer.h
    Removed EXT_LEXER_DECL definition from typedefs.

ext/scintilla/sci_generator.php
    Fixed to be compatible with the new LineOutput class. Also removed deprecated functions and warnings.

There is also some dependency problem in the makefile, so one has to manually make gen_scintilla.c:

make ext/scintilla/gen_scintilla.c
make



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=52274&edit=1

--
PHP-GTK Development Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php