GtkLinkButton signal needs minimum GTK+ requirements

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

GtkLinkButton signal needs minimum GTK+ requirements

Igor Korot
Hi, ALL,
Is this an oversight? I don't see this minimum GTK+ version for that signal...

Thank you.
_______________________________________________
gtk-doc-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtk-doc-list
Reply | Threaded
Open this post in threaded view
|

Re: GtkLinkButton signal needs minimum GTK+ requirements

Igor Korot
Stefan,

On Wed, Jul 29, 2015 at 6:09 AM, Stefan Sauer <[hidden email]> wrote:
> On 07/28/2015 12:47 PM, Igor Korot wrote:
>> Hi, ALL,
>> Is this an oversight? I don't see this minimum GTK+ version for that signal...
> Please file a bug with patch into bugzilla for product=gtk+. This list
> is for discussion on the gtk-doc tool.

But what do I put in the patch.

I have no idea what is the minimum requirements...

Thank you.

>
> Thanks!
> Stefan
_______________________________________________
gtk-doc-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtk-doc-list
Reply | Threaded
Open this post in threaded view
|

Re: GtkLinkButton signal needs minimum GTK+ requirements

Stefan Sauer-4
On 07/29/2015 12:39 PM, Igor Korot wrote:

> Stefan,
>
> On Wed, Jul 29, 2015 at 6:09 AM, Stefan Sauer <[hidden email]> wrote:
>> On 07/28/2015 12:47 PM, Igor Korot wrote:
>>> Hi, ALL,
>>> Is this an oversight? I don't see this minimum GTK+ version for that signal...
>> Please file a bug with patch into bugzilla for product=gtk+. This list
>> is for discussion on the gtk-doc tool.
> But what do I put in the patch.
>
> I have no idea what is the minimum requirements...
>
> Thank you.
>

Are you saying that
https://developer.gnome.org/gtk3/stable/GtkLinkButton.html#GtkLinkButton-activate-link
this API misses since docs? Using git blame we can find the commit that
added the signal and according to
$ git describe 17ffcb0c
2.91.0-153-g17ffcb0

It is there since gtk+3.0 and usually we don't add a since tag then.

Stefan
_______________________________________________
gtk-doc-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtk-doc-list
Reply | Threaded
Open this post in threaded view
|

Re: GtkLinkButton signal needs minimum GTK+ requirements

Igor Korot
Stefan,

On Wed, Jul 29, 2015 at 3:32 PM, Stefan Sauer <[hidden email]> wrote:

> On 07/29/2015 12:39 PM, Igor Korot wrote:
>> Stefan,
>>
>> On Wed, Jul 29, 2015 at 6:09 AM, Stefan Sauer <[hidden email]> wrote:
>>> On 07/28/2015 12:47 PM, Igor Korot wrote:
>>>> Hi, ALL,
>>>> Is this an oversight? I don't see this minimum GTK+ version for that signal...
>>> Please file a bug with patch into bugzilla for product=gtk+. This list
>>> is for discussion on the gtk-doc tool.
>> But what do I put in the patch.
>>
>> I have no idea what is the minimum requirements...
>>
>> Thank you.
>>
>
> Are you saying that
> https://developer.gnome.org/gtk3/stable/GtkLinkButton.html#GtkLinkButton-activate-link
> this API misses since docs? Using git blame we can find the commit that
> added the signal and according to
> $ git describe 17ffcb0c
> 2.91.0-153-g17ffcb0
>
> It is there since gtk+3.0 and usually we don't add a since tag then.

Thx for clarification.

>
> Stefan
_______________________________________________
gtk-doc-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtk-doc-list