Docs and gkt versions

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Docs and gkt versions

Fernando Correa da Conceição-3
I would like to propose a new information on the docs, something like:
<note>
  <para>
    This function is only available when php-gtk is build using Gtk 2.12
or a later version.
  </para>
</note>

So the user know that if the function needs a recent version of php-gtk.
The php manual have this kind of info for every function.
Can I do this? Any ideas ?

--
PHP-GTK Documentation Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Re: Docs and gkt versions

Elizabeth M Smith
Fernando Correa da Conceição wrote:

> I would like to propose a new information on the docs, something like:
> <note>
>  <para>
>    This function is only available when php-gtk is build using Gtk 2.12
> or a later version.
>  </para>
> </note>
>
> So the user know that if the function needs a recent version of php-gtk.
> The php manual have this kind of info for every function.
> Can I do this? Any ideas ?

Actually that's a REALLY good idea, especially since the gtk library
also starts deprecating stuff at different versions as well - PHP itself
has some kind of versioning - can we steal from them?

Thanks,
Elizabeth

--
PHP-GTK Documentation Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Re: Re: Docs and gkt versions

Fernando Correa da Conceição-3
Elizabeth M Smith escreveu:

> Fernando Correa da Conceição wrote:
>> I would like to propose a new information on the docs, something like:
>> <note>
>>  <para>
>>    This function is only available when php-gtk is build using Gtk
>> 2.12 or a later version.
>>  </para>
>> </note>
>>
>> So the user know that if the function needs a recent version of
>> php-gtk. The php manual have this kind of info for every function.
>> Can I do this? Any ideas ?
>
> Actually that's a REALLY good idea, especially since the gtk library
> also starts deprecating stuff at different versions as well - PHP
> itself has some kind of versioning - can we steal from them?
>
> Thanks,
> Elizabeth
>
The deprecated, one by one, but we can:
http://library.gnome.org/devel/gtk/stable/api-index-deprecated.html
And for the new functions
http://library.gnome.org/devel/gtk/stable/api-index-2-10.html and there
is the same kind of list for all versions.

Fernando.


--
PHP-GTK Documentation Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Re: Re: Docs and gkt versions

Elizabeth M Smith
Fernando Correa da Conceição wrote:

> Elizabeth M Smith escreveu:
>> Fernando Correa da Conceição wrote:
>>> I would like to propose a new information on the docs, something like:
>>> <note>
>>>  <para>
>>>    This function is only available when php-gtk is build using Gtk
>>> 2.12 or a later version.
>>>  </para>
>>> </note>
>>>
>>> So the user know that if the function needs a recent version of
>>> php-gtk. The php manual have this kind of info for every function.
>>> Can I do this? Any ideas ?
>>
>> Actually that's a REALLY good idea, especially since the gtk library
>> also starts deprecating stuff at different versions as well - PHP
>> itself has some kind of versioning - can we steal from them?
>>
>> Thanks,
>> Elizabeth
>>
> The deprecated, one by one, but we can:
> http://library.gnome.org/devel/gtk/stable/api-index-deprecated.html
> And for the new functions
> http://library.gnome.org/devel/gtk/stable/api-index-2-10.html and there
> is the same kind of list for all versions.
>
> Fernando.
>

I meant PHP has versioning information (5.2, 5.3, 6.0, etc) in it's docs
- can we steal the markup

Thanks,
Elizabeth

--
PHP-GTK Documentation Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Re: Re: Docs and gkt versions

Fernando Correa da Conceição-3
Elizabeth M Smith escreveu:

> Fernando Correa da Conceição wrote:
>> Elizabeth M Smith escreveu:
>>> Fernando Correa da Conceição wrote:
>>>> I would like to propose a new information on the docs, something like:
>>>> <note>
>>>>  <para>
>>>>    This function is only available when php-gtk is build using Gtk
>>>> 2.12 or a later version.
>>>>  </para>
>>>> </note>
>>>>
>>>> So the user know that if the function needs a recent version of
>>>> php-gtk. The php manual have this kind of info for every function.
>>>> Can I do this? Any ideas ?
>>>
>>> Actually that's a REALLY good idea, especially since the gtk library
>>> also starts deprecating stuff at different versions as well - PHP
>>> itself has some kind of versioning - can we steal from them?
>>>
>>> Thanks,
>>> Elizabeth
>>>
>> The deprecated, one by one, but we can:
>> http://library.gnome.org/devel/gtk/stable/api-index-deprecated.html
>> And for the new functions
>> http://library.gnome.org/devel/gtk/stable/api-index-2-10.html and
>> there is the same kind of list for all versions.
>>
>> Fernando.
>>
>
> I meant PHP has versioning information (5.2, 5.3, 6.0, etc) in it's
> docs - can we steal the markup
>
> Thanks,
> Elizabeth
>
No, i work on phpdoc-pt_BR, the version info is not on the docs(xml
files), it is put by build system.
We can put it as this:
 
 <simpara>
     (Gtk 2.8)
   </simpara>

After <desc> but it will be simple text, not tagged as a version, or
wait until we make phd work for php-gtk for this.




--
PHP-GTK Documentation Mailing List (http://gtk.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php