Cross compiling gimp with mingw-w64 requires pangoft2 that is not available

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cross compiling gimp with mingw-w64 requires pangoft2 that is not available

YuGiOhJCJ Mailing-List
Hello,

Programs used:
- gimp-2.8.16
- cairo-1.14.2
- pango-1.39.0
- fontconfig-2.11.1
- freetype-2.4.10

How I compile pango for Windows:
$ ./configure --prefix=/usr/i686-w64-mingw32 --host=i686-w64-mingw32
$ make

When I cross compile gimp with mingw-w64 [1] I got an error telling I need pango with the optional support for cairo [2] but I already have installed pango and its cairo support.

Reading more carefully the config.log file, I see that "pangoft2" is checked too at this step [3] and that's why this error is shown.

So, I need pangoft2 but I don't think it is possible to build pango with pangoft2 for win32 platform.

Indeed, when I compile pango for Linux, I got pangoft2, but when I compile pango for Windows, the pangoft2 library does not come with it.

As gimp depends on pangoft2, I can't build gimp with mingw-w64.

Is it possible to build pango with pangoft2 for win32 platform?

Thank you.
Best regards.

[1] http://wiki.gimp.org/wiki/Hacking:Building/Windows#Build_GIMP

[2] Error while compiling gimp for Windows:
./configure --prefix=/usr/i686-w64-mingw32 --host=i686-w64-mingw32 --enable-introspection=no --disable-glibtest --disable-gtktest --disable-docs --without-libjpeg --disable-python --without-xmc --without-dbus --without-libzma
[...]
checking for CAIRO... yes
checking for PANGOCAIRO... no
configure: error: Test for PangoCairo failed.
*** We require Pango with the optional support for Cairo compiled in.
*** See the file 'INSTALL' for more help.

[3] The config.log file after trying to compile gimp for Windows:
$ cat config.log
[...]
configure:18051: checking for CAIRO
configure:18058: $PKG_CONFIG --exists --print-errors "cairo >= 1.10.2"
configure:18061: $? = 0
configure:18075: $PKG_CONFIG --exists --print-errors "cairo >= 1.10.2"
configure:18078: $? = 0
configure:18136: result: yes
configure:18143: checking for PANGOCAIRO
configure:18150: $PKG_CONFIG --exists --print-errors "pangocairo >= 1.29.4 pangoft2"
Package pangoft2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pangoft2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pangoft2' found
configure:18153: $? = 1
configure:18167: $PKG_CONFIG --exists --print-errors "pangocairo >= 1.29.4 pangoft2"
Package pangoft2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `pangoft2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pangoft2' found
configure:18170: $? = 1
configure:18184: result: no
No package 'pangoft2' found
configure:18200: error: Test for PangoCairo failed.
*** We require Pango with the optional support for Cairo compiled in.
*** See the file 'INSTALL' for more help.
[...]
_______________________________________________
gtk-i18n-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/gtk-i18n-list
Loading...