Compilation Issues -- Gtk and Gpe

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilation Issues -- Gtk and Gpe

Maximus-2
Hi,
    I dont have cross compiled gtk libraries for arm on my system.

    eventually, i want to compile GPE.

    But, GPE needs GTK Libs.

    so, i downloaded latest gtk 2.6.6.

   when i say ./configure it says u dont have glibc >= 2.60.


    i have already compiled and installed glibc and cross tools and
applications they depend on glibc 2.3.2   and gcc-3.4.1.


   What should i do. should i need 2 versions of glibc. one for gtk
and one for cross tools and other utilities. ( this is not possbile).

I want a gtk that needs glibc 2.3.2 and not 2.60 .


What should i do. if i want glibc 2.60. i should start all over again
which is time consuming.


Please advice.



/J
_______________________________________________
gtk-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/gtk-list
Reply | Threaded
Open this post in threaded view
|

Re: [Gpe] Compilation Issues -- Gtk and Gpe

Chris Lord
On Tue, 2005-06-07 at 10:09 -0400, John Smith wrote:

>    when i say ./configure it says u dont have glibc >= 2.60.

Are you sure it doesn't say you don't have *glib* >= 2.60?


Chris Lord

_______________________________________________
gtk-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/gtk-list
Reply | Threaded
Open this post in threaded view
|

Re: [Gpe] Compilation Issues -- Gtk and Gpe

Maximus-2
Hi,
    My environmental variable points to the directory containing all
the cross-compiled.
   LDFLAGS=-L/usr/local/arm/3.4.1/arm-linux/lib.

  There is one glib-2.0.pc but, it is in /usr/lib which contains all
the native libraries.


 I dont know how to solve the problem.

 please do advice.


i have appended the output of configure.



/J


[user@LocalSystem gtk+-2.6.6]$ ./configure --host=arm

checking for /usr/local/arm/3.4.1/bin/arm-linux-gcc option to accept
ANSI C... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... (cached) yes
checking for glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0...
Package glib-2.0 was not found in the pkg-config search path. Perhaps
you should add the directory containing `glib-2.0.pc' to the
PKG_CONFIG_PATH environment variable No package 'glib-2.0' found
configure: error: Library requirements (glib-2.0 >= 2.6.0    atk >=
1.0.1    pango >= 1.8.0) not met; consider adjusting the
PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.
[user@LocalSystem gtk+-2.6.6]$


On 6/7/05, Chris Lord <[hidden email]> wrote:

> On Tue, 2005-06-07 at 10:09 -0400, John Smith wrote:
>
> >    when i say ./configure it says u dont have glibc >= 2.60.
>
> Are you sure it doesn't say you don't have *glib* >= 2.60?
>
>
> Chris Lord
>
> _______________________________________________
> GPE mailing list
> [hidden email]
> http://handhelds.org/mailman/listinfo/gpe
>
_______________________________________________
gtk-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/gtk-list
Reply | Threaded
Open this post in threaded view
|

Re: [Gpe] Compilation Issues -- Gtk and Gpe

Philippe De Swert
In reply to this post by Maximus-2
Hello John,

> Hi,
>     My environmental variable points to the directory containing all
> the cross-compiled.
>    LDFLAGS=-L/usr/local/arm/3.4.1/arm-linux/lib.
>
>   There is one glib-2.0.pc but, it is in /usr/lib which contains all
> the native libraries.
>
>
>  I dont know how to solve the problem.
>  please do advice.

please do read your error message completely and in detail. Often the solution
is easily found..

> [user@LocalSystem gtk+-2.6.6]$ ./configure --host=arm
>
> checking for /usr/local/arm/3.4.1/bin/arm-linux-gcc option to accept
> ANSI C... none needed
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether make sets $(MAKE)... (cached) yes
> checking for glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0...
> Package glib-2.0 was not found in the pkg-config search path. Perhaps
> you should add the directory containing `glib-2.0.pc' to the
> PKG_CONFIG_PATH environment variable No package 'glib-2.0' found
> configure: error: Library requirements (glib-2.0 >= 2.6.0    atk >=
> 1.0.1    pango >= 1.8.0) not met; consider adjusting the
> PKG_CONFIG_PATH environment variable if your libraries are in a
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

So basically make sure your PKG_CONFIG_PATH is correct and points to the
glib-2.0.pc file you want to use..

You can use pkg-config --list-all to check if your glib-2.0.pc is included
after adjusting the PKG_CONFIG_PATH.

Cheers,

Philippe

| Philippe De Swert
|
| Stag developer http://stag.mind.be/
| Emdebian developer: http://www.emdebian.org
|
| Please do not send me documents in a closed
| format.(*.doc,*.xls,*.ppt)
| Use the open alternatives. (*.pdf,*.ps,*.html,*.txt)
| http://www.gnu.org/philosophy/no-word-attachments.html 

-------------------------------------------------------
NOTE! My email address is changing to ... @scarlet.be
Please make the necessary changes in your address book.



_______________________________________________
gtk-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/gtk-list