CinePaint universal build issues

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

CinePaint universal build issues

Bugzilla from ku.b@gmx.de
Hello,

as Robin said, he would like to look at gtk-osx, I just want to give some
infos about my last state for compiling CinePaint with this Gtk branch.

After the last talk on the CinePaint developers list I tried a Tiger
universal build with Gtk1 CinePaint v0.22-1. All deps where in place. Just
the CinePaint build did not run as expected on my G4 ppc test machine. For
intel I could not test.
Probably all is fine with building separately for ppc and intel.

I modified the G_ENDIAN style macros after configure, and exchanged
against runtime versions. In the same way I could change libtiff [1] to
open my test images properly. The other libs are probably not out of the
box osX universal binary ready.
Still the CinePaint build where not much useable. I could not draw.
The mouse position seems to be fixed. Even though the gradient,
selection and fill tools as well as colour selection and CMS worked.
Oh just fixed a Gtk1 bug in CinePaint CVS.
The outlined endianess gtk-osx changes are not included in my last patch
[2].

[1] http://www.asmail.be/msg0055159178.html
[2] http://sourceforge.net/tracker/index.php?func=detail&aid=1816608&group_id=70160&atid=526809


regards,
Kai-Uwe Behrmann
--
developing for colour management
www.behrmann.name + www.oyranos.org


PS: btw. gettext/libtool is always a pain to compile, uhh.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >> http://get.splunk.com/
_______________________________________________
Gtk-osx-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gtk-osx-developer